SSL - Comodo
Incident Report for OpenSRS
Resolved
-
We are happy to report that our connection to Comodo is now back online. Orders may not be processed as needed.
Posted 2 months ago. Aug 08, 2018 - 19:30 UTC
Investigating
There are ongoing connection issues with Comodo.

This will impact customer's ability to order & manage Comodo products.

More updates will be available shortly.
Posted 2 months ago. Aug 08, 2018 - 18:29 UTC
This incident affected: SSL.