Symantec, Geotrust, Thawte, RapidSSL email delays.
Incident Report for OpenSRS
Resolved
Symantec has confirmed that a fix was deployed. Customers should expect standard delivery times for Symantec SSL emails.
Posted Apr 19, 2019 - 15:50 UTC
Investigating
Customers purchasing Symantec and subsidiary branded SSL products may experience email delivery delays from the vendor that last roughly 30~ minutes.

This will impact both domain control validation communications, and SSL fulfillment communications.

Symantec has not yet disclosed an ETA on the resolution of this issue. OpenSRS will continue to periodically ask the vendor and post updates should a timeline or resolution become available.

We will update this post when more details become available
Posted Apr 18, 2019 - 13:31 UTC
This incident affected: SSL.