Domain Approval Links
Incident Report for OpenSRS
Resolved
We should be all set now and are reviewing what happened. Thanks for bearing with us.

Incident Start Time: 03-20-2021 13:34:00 UTC
Incident End Time: 03-20-2021 16:52:00 UTC
Total Duration: 3 hours 18 minutes
Posted Mar 20, 2021 - 17:14 UTC
Investigating
We're aware of an issue impacting domain transfer, GDPR consent and registrant verification links and are working to resolve it as quickly as possible.
Posted Mar 20, 2021 - 16:31 UTC
This incident affected: Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs, Other ccTLDs).