Outbound Support Emails

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted May 26, 2025 - 17:26 UTC

Investigating

We are currently experiencing an issue with the Reseller Support Department's outbound emails, an issue related to our support software. This is currently being investigated, and we will follow up as updates become available.

Note: this has no impact on our own Hosted Email service, or automated emails sent to domain owners and resellers about domains, SSL and accounts.
Posted May 26, 2025 - 14:27 UTC
This incident affected: Reseller Support.