Cluster A - IMAP and Webmail
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 19:50 UTC
Investigating
Cluster A Users may experience difficulties accessing webmail and/or fetching new mail over IMAP.

Our team is investigating the issue.

Next update: 20:00UTC
Posted Mar 20, 2020 - 19:33 UTC
This incident affected: Hosted Email (Cluster A, Webmail).