Domain Services
Incident Report for OpenSRS
Resolved
The issues we were experiencing with domain services are now fully resolved.
Posted 3 months ago. May 30, 2018 - 00:02 UTC
Monitoring
Our operations team was able to quickly resolve the issues we were experiencing with domain registration and management. We are continuing to monitor the situation.
Posted 3 months ago. May 29, 2018 - 23:47 UTC
Investigating
Our operations team is investigating an issue impacting domain registration and management. Order processing and domain management may fail at this time. We will update this status as more information is available.
Posted 3 months ago. May 29, 2018 - 23:28 UTC
This incident affected: Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs, Other ccTLDs).