Cluster B - all email services
Incident Report for OpenSRS
Postmortem

Incident Date: June 24, 2021
Incident Number: PR-2109

On June 24, 2021 at 10:56 AM ET, Tucows’ hosted email platform experienced service interruption impacting IMAP, POP, and Webmail in Prod B. Tucows’ Network Engineering team was engaged to investigate the issue.

The service interruption was caused due to a DDoS attack. 

At 11:21 AM ET, the DDoS traffic subsided and the issue recovered without any intervention. 

Tucows is to continue working with existing vendors to improve DDoS mitigation services to address and rectify DDoS attacks in a timely manner.

Tucows is to enhance the monitoring for better visibility. 

Thank you,

Tucows Engineering Team

Posted Jun 28, 2021 - 20:16 UTC

Resolved
Our operations team has determined the cause of service interruption was a DDoS attack. Services continue to be stable.

Incident Start Time: 06-24-2021 14:56:00
Incident End Time:06-24-2021 15:21:00
Total Duration:25 minutes
Posted Jun 24, 2021 - 15:52 UTC
Monitoring
We are continuing to monitor the situation and services are operating normally.
Posted Jun 24, 2021 - 15:38 UTC
Identified
Our engineering team has found the cause of the issue and services are recovering back to normal. We will provide more details in the incident report.
Posted Jun 24, 2021 - 15:30 UTC
Investigating
Our engineering team is currently investigating an issue impacting users on cluster B. Users may experience issues logging into webmail or loading the page. We will provide more updates as they become available.
Posted Jun 24, 2021 - 15:22 UTC
This incident affected: Hosted Email (Cluster B, Webmail).