TrustWave SSL Certificate Issue
Incident Report for OpenSRS
Resolved
The connections to Trustwave have been restored and all Trustwave SSL products can now be ordered again as of Feb 14 2021 8:15am UTC. The total download for these orders was 18hours:15minutes.

Incident Start Time: 02-13-2021 14:00:00 UTC
Incident End Time: 02-14-2021 08:15:00 UTC
Total Duration: 18 hours and 15 minutes
Posted Feb 14, 2021 - 09:42 UTC
Update
We are still awaiting a response from the vendor regarding their investigation. Further updates will be provided once available.
Posted Feb 14, 2021 - 00:01 UTC
Update
Trustwave has escalated the issue to their engineering team and they are currently investigating the issue. We will provide further updates as they are available.
Posted Feb 13, 2021 - 20:26 UTC
Update
The issue with placing TrustWave SSL orders is still being investigated.
We will continue to provide updates as they become available.
Posted Feb 13, 2021 - 19:17 UTC
Update
Our engineering team is still currently engaged on this issue with Trustwave.
We will continue to provide updates as they become available.
Posted Feb 13, 2021 - 17:49 UTC
Update
Our engineering team is still working on this issue with TrustWave.
We will continue to provide updates as they become available.
Posted Feb 13, 2021 - 16:59 UTC
Update
We are currently experiencing issues placing TrustWave SSL orders at the moment. We are reaching out to the vendor in order to resolve this matter and we will post updates as soon as possible.
Posted Feb 13, 2021 - 15:11 UTC
Investigating
We are currently investigating this issue.
Posted Feb 13, 2021 - 14:35 UTC
This incident affected: SSL.