Cluster B - Webmail/POP

Incident Report for OpenSRS

Resolved

Engineering has issued a fix and services have returned to normal. This incident is resolved.
Posted Feb 26, 2026 - 18:49 UTC

Investigating

We are experiencing an issue involving webmail and POP3 connectivity on Cluster B of Hosted Email. Webmail and POP access is impacted. Engineering is engaged and investigating.
Posted Feb 26, 2026 - 18:19 UTC
This incident affected: Hosted Email (Cluster B, Webmail).