API/RCP Slowness and Timeouts

Incident Report for OpenSRS

Resolved

Our engineers have deployed a fix and API functionality is back to normal. This incident has been resolved.
Posted May 26, 2025 - 20:35 UTC

Investigating

Our engineers are aware of an issue impacting domain lookups causing slow response times and timeouts. They are currently investigating. Further updates will be provided.
Posted May 26, 2025 - 19:54 UTC
This incident affected: APIs (OpenSRS API).