SSL | Comodo service is down
Incident Report for OpenSRS
Resolved
The Service has been restored. The outage was caused by maintenance being performed by Sectigo.

Thank you for your patience.
Posted Jan 13, 2020 - 16:53 UTC
Investigating
We are currently experiencing an issue with Comodo's service. Resellers may find their Comodo SSL orders failing while this problem is being investigated. We've reached out to the SSL provider and will provide updates as soon as we can
Posted Jan 13, 2020 - 16:22 UTC
This incident affected: SSL.