Digicert maintenance is ongoing
Incident Report for OpenSRS
Resolved
SSL orders for Geotrust brands should now be working correctly after their maintenance has been completed
Posted 2 months ago. Apr 07, 2019 - 08:48 UTC
Monitoring
We verified the Digicert maintenance is still ongoing and while a definite time was not provided its estimated to be functional again after about an hour. During this time placing Digicert orders will likely respond with errors and fail.
Posted 2 months ago. Apr 07, 2019 - 04:46 UTC
This incident affected: SSL.