Cluster B - IMAP/POP/SMTP/Webmail
Incident Report for OpenSRS
Resolved
After additional testing, we can validate that the service is working as intended for the remaining group of impacted users. Please reach out to our support team should the issue persist.
Posted Apr 04, 2020 - 21:37 UTC
Update
Our customer base is reporting that a majority of the imapacted users have now recovered.

We're closely monitoring the situation and continuing to work on the remaining users that cannot access their services at this time.
Posted Apr 04, 2020 - 21:24 UTC
Investigating
We continue to receive reports from resellers about the outage that was presumed solved.

Our team is investigating based on the examples and feedback produced from these reports.

Next update: 21:15UTC
Posted Apr 04, 2020 - 21:00 UTC
This incident affected: Hosted Email (Cluster B, Webmail).