Sectigo SSL Certificate Validation Issue
Incident Report for OpenSRS
Resolved
Our team has identified the issue and has deployed a fix to resolve the issue. Services should resume as normal.

Incident Start Time: 09-21-2021 00:00 AM UTC
Incident End Time: 09-21-2021 5:17 AM UTC
Incident Duration: 5 hours 17 minutes
Posted Sep 21, 2021 - 05:38 UTC
Update
Our engineering team is continuing to look into this issue.

Next Update: Within 60 minutes
Posted Sep 21, 2021 - 04:31 UTC
Update
Our team is aware of this issue and has reached out to Sectigo for an update.
Posted Sep 21, 2021 - 03:48 UTC
Investigating
We are experiencing degradation of service.

Users may be unable to authenticate/validate Sectigo/COMODO SSL certificates at this time
Posted Sep 21, 2021 - 00:00 UTC
This incident affected: SSL.