.COM - Domain Availability Lookups returning incorrect data
Incident Report for OpenSRS
Postmortem

Incident Date: September 28, 2020
Incident Number: PR-1371

On September 28, 2020 at 1:54 PM ET we experienced intermittent issues with Tucows’ Domains platform where Domain Availability Lookups were showing domains as taken when available. Tucows Engineers were engaged and started investigating the issue.

The service interruption was caused due to the caching issue retaining incorrect data. 

On October 1, 2020 at 1:13 PM ET, The engineering team migrated the services from the legacy system and brought the services online on the new Domain Lookup System to restore them successfully.

Tucows is to review and enhance monitoring for better visibility. 

Tucows has moved all services to the new system and will be decommissioning the legacy system.

Thank you,

Tucows Engineering Team

Posted Oct 06, 2020 - 21:03 UTC

Resolved
Our engineering team has resolved the issue.

Incident Start Time: 09-28-2020 17:54:00 UTC
Incident End Time: 10-01-2020 17:13:00 UTC
Total Duration: 2 days 23 hours and 19 minutes
Posted Oct 01, 2020 - 17:32 UTC
Identified
We have identified an issue with Domain Availability lookups for .COM domains. This is impacting the reseller control panel only, API can set no_cache to 1 and return results successfully. Engineers are working to mitigate the issue.
Posted Oct 01, 2020 - 17:11 UTC
This incident affected: Domain Services (Core gTLDs) and Reseller Support.