.ZA Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that the .ZA registry connection is back online. Any pending orders may not be processed.
Posted 3 months ago. May 02, 2019 - 12:57 UTC
Investigating
We are currently having connection issues with the .ZA registry. The registry might be experiencing a temporary outage or undergoing maintenance. Our operations team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of .ZA domains. Existing domains will continue to resolve normally.

Affected TLDs:
org.za, net.za, .web.za, co.za
Posted 3 months ago. May 02, 2019 - 12:47 UTC
This incident affected: Domain Services (Other ccTLDs).