Cluster A - Inbound Delays, Slowness, IMAP Failures
Incident Report for OpenSRS
Resolved
This incident has been resolved by our engineering team.

Incident start time: 02/20/2024 - 15:30 UTC
Incident end time: 02/20/2024 - 17:04 UTC
Total Duration: 1hr and 34 minutes
Posted Feb 20, 2024 - 17:26 UTC
Update
We are continuing to investigate this issue.
Posted Feb 20, 2024 - 16:18 UTC
Investigating
We are currently experiencing inbound mail delays, slowness, and IMAP failures on Cluster A. Our engineering team is investigating the issue.

We will provide an update once we have additional information.
Posted Feb 20, 2024 - 16:17 UTC
This incident affected: Hosted Email (Cluster A, Webmail).