tucows.com website degradation

Incident Report for OpenSRS

Resolved

This incident has been resolved and all services are fully operational.

Incident Start Time: 09-19-2020 19:49:00 UTC
Incident End Time: 09-19-2020 21:38:00 UTC
Total Duration: 1 hour and 49 minutes
Posted Sep 20, 2020 - 12:46 UTC

Monitoring

Mitigation has been implemented to disperse the abusive traffic, tucows.com is currently accessible but our engineering teams are monitoring for potential threats. We will continue to keep this issue on alert for time being.
Posted Sep 19, 2020 - 21:19 UTC

Identified

We are seeing abusive traffic hitting our servers impacting tucows.com, our engineers are working to mitigate service impact.
Posted Sep 19, 2020 - 20:11 UTC