Investigating Connectivity Issues – .DE, .CH, .FR Registries

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 17:57 UTC

Investigating

We are currently receiving reports of connection issues with the .DE, .CH, and .FR registries when attempting to renew or register domains.

Our team is actively investigating the cause and working to restore normal functionality.

Thank you for your patience, we will provide updates as soon as more information is available.
Posted Dec 06, 2025 - 16:47 UTC
This incident affected: Domain Services (Core ccTLDs).