Connectivity issues with Sectigo (SSL)
Incident Report for OpenSRS
Resolved
The connection issues with Sectigo have been resolved without any actions being taken. Any followup details regarding this interruption will be provided on this post.

Start time 01-19-2023 10:52:00 UTC
End Time 01-19-2023 13:40:00 UTC

Duration 2 hours 48 minutes
Posted Jan 19, 2023 - 13:27 UTC
Update
We are currently experiencing connectivity errors with trust provider Sectigo/Comodo and we have reached out to them for more information. Sectigo orders will experience latency issues and may not appear on the Trust list when placing orders. We will provide additional updates as they become available.
Posted Jan 19, 2023 - 11:24 UTC
Investigating
We are currently investigating this issue.
Posted Jan 19, 2023 - 11:12 UTC
This incident affected: SSL.