Geotrust Connection Degradation
Incident Report for OpenSRS
Resolved
We have had no new reports or incidents related to Geotrust and portal access remains accessible, this matter is now resolved.
Posted Oct 31, 2019 - 00:58 UTC
Monitoring
Geotrust has implemented a fix and we are continuing to monitor results, service should be operational again and Geotrust orders can now be processed.
Posted Oct 31, 2019 - 00:17 UTC
Investigating
We are currently getting invalid results when communicating with Geotrust. Transactions for Geotrust orders which require action by Geotrust will be unsuccessful and portal is inaccessible currently. We have reached out to inquire and will update when we have more information..
Posted Oct 30, 2019 - 20:30 UTC
This incident affected: SSL.