Nuestar Registry connection is still under maintenance
Incident Report for OpenSRS
Resolved
The Neustar registry maintenance has completed and domain lookups and orders are working again.
Posted Jul 13, 2021 - 10:52 UTC
Monitoring
The Neustar registry maintenance has gone over the provided time frame provided by the registry. We will monitor the registry connections until they are restored. In the meantime Neustar TLDs will fail to load correctly and orders for these TLDs will also fail.

To see the affected TLDs please check the TLD list for Neustar domains
http://opensrs.help/tlds
Posted Jul 13, 2021 - 08:33 UTC
This incident affected: Domain Services (Other gTLDs).