Phone Support Service Interruption
Incident Report for OpenSRS
Resolved
All services are confirmed to be working. This incident is now closed.
Posted Jun 13, 2023 - 21:29 UTC
Monitoring
Our support team is now able to successfully receive phone calls, we appreciate your patience during this time. We will continue to monitor for a short period before closing this status page.
Posted Jun 13, 2023 - 21:13 UTC
Investigating
We are currently experiencing an issue with our 3rd party provider for VoIP phone support.

While we wait for this to be resolved, we can still be contacted via live chat at opensrs.com and can also be emailed at help@opensrs.com as well.

We thank you for your understanding.
Posted Jun 13, 2023 - 20:35 UTC
This incident affected: Reseller Support.