.EU Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that our operations team was able to address the issue affecting our connections to the registry. Services are now functioning as they should. Thank you for your patience in the matter.
Posted 5 months ago. May 16, 2018 - 10:11 UTC
Investigating
We are currently experiencing connection issues with the .EU registry, following the maintenance that concluded at 07:00 UTC. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .EU domains. Existing domains will continue to resolve normally.
Posted 5 months ago. May 16, 2018 - 07:57 UTC
This incident affected: Domain Services (Core ccTLDs).