Cluster A - Inbound Delays
Incident Report for OpenSRS
Resolved
Our engineering team was able to clear up the inbound delays, we haven't seen any further reports of delays. This incident is considered resolved.

Incident Start Time: 03-15-2021 16:10:00
Incident End Time:03-15-2021 20:03:00
Total Duration:3 hrs, 57 min
Posted Mar 15, 2021 - 20:21 UTC
Update
Our engineering team still works to clear out the inbound delays we are seeing improvements but there are still delays for some customers. We'll continue to provide updates as they come.
Posted Mar 15, 2021 - 18:32 UTC
Update
We are still observing inbound email delays. Our engineering team is continuing to work on a resolution. We will provide further updates as soon as they become available.
Posted Mar 15, 2021 - 17:26 UTC
Investigating
We are currently experiencing inbound mail delays on Cluster A. Our engineering team is investigating the issue.

We will provide an update once we have additional information.
Posted Mar 15, 2021 - 16:24 UTC
This incident affected: Hosted Email (Cluster A).