Ongoing Comodo Maintenance
Incident Report for OpenSRS
Resolved
The ongoing Comodo maintenance has now completed.
Posted 23 days ago. Jul 05, 2017 - 19:31 UTC
Monitoring
Over the next few weeks Comodo will be performing sporadic maintenance. During these maintenance periods we will not be able to process any updates or transactions. If you receive an error when processing a request please try again in an hour. If you continue to experience errors please contact support.
Posted about 1 month ago. Jun 14, 2017 - 11:13 UTC
This incident affected: SSL.