Cluster B - Webmail/POP/IMAP

Incident Report for OpenSRS

Resolved

Engineering has implemented a fix which has resovled this incident.
Posted Mar 10, 2026 - 15:46 UTC

Investigating

We are currently facing a problem impacting Webmail, POP3, and IMAP on the HostedEmail cluster B. Users might find themselves unable to log in or send and receive messages. The engineering team is actively looking into the matter, and additional updates will be shared as they become available.
Posted Mar 10, 2026 - 15:13 UTC
This incident affected: Hosted Email (Cluster B, Webmail).