Cluster B - Webmail Login
Incident Report for OpenSRS
Postmortem

Incident Date: November 19, 2020
Incident Number: PR-1512

On November 19, 2020 at 2:00 PM ET, Tucows hosted email platform experienced inbound email deferrals impacting Prod B.

The issue was caused due to high volume of incoming email.

At 3:16 PM ET, Tucows engineering team blocked the abusive traffic and the services came back online.

Due to the continuous change in the traffic pattern, we experienced additional service interruptions to webmail in prod B:

From 3:19 PM ET to 3:25 PM ET 
From 3:28 PM ET to 3:34 PM ET

At 3:34 PM ET, All the services recovered successfully.

Tucows engineering is to improve logging and enhance monitoring visibility to identify issues in a timely manner. 

Tucows has further enhanced the security measures to better identify and block the abusive traffic. 

Thank you,

Tucows Engineering Team

Posted Nov 28, 2020 - 22:45 UTC

Resolved
All the services have been restored successfully. We will be conducting a full investigation into the root cause and publishing more details once complete.

Incident Start Time: 11-19-2020 20:08:00 UTC
Incident Start Time: 11-19-2020 20:34:00 UTC
Total Duration: 26 minutes
Posted Nov 19, 2020 - 20:54 UTC
Investigating
We are investigating an issue preventing some users on Cluster B from logging into Webmail. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Nov 19, 2020 - 20:24 UTC
This incident affected: Hosted Email (Cluster B).