Sectigo Order Processing Status

Incident Report for OpenSRS

Resolved

We were able to identify the issues causing new Sectigo Trust orders to get stuck in a "processing" status. Those orders have been corrected and they now display the correct order status.
Posted Mar 22, 2024 - 15:49 UTC

Update

We are continuing to investigate this issue.
Posted Mar 15, 2024 - 15:37 UTC

Investigating

We are currently investigating an issue impacting Sectigo order status displaying 'processing' in the Reseller Control Panel. These orders are being processed by Sectigo but the control panel is not showing the order status with Sectigo. Further updates will be provided.
Posted Mar 05, 2024 - 20:57 UTC
This incident affected: Control Panels (Reseller Control Panel) and SSL.