Cluster B - Inbound Delays
Incident Report for OpenSRS
Resolved
This incident has been resolved.

Incident Start Time: 07-25-2020 18:33:00 UTC
Incident End Time:07-25-2020 20:20:00 UTC

Total Duration:1hr 47 min.
Posted Jul 25, 2020 - 20:33 UTC
Monitoring
Our engineering team implemented a fix and the queued mail is being delivered now. All services are restored at present. We will keep monitoring the issue.
Posted Jul 25, 2020 - 20:14 UTC
Investigating
We are currently experiencing inbound mail delays on Cluster B. Our engineering team is investigating the issue.

We will provide an update once we have additional information.
Posted Jul 25, 2020 - 19:51 UTC
This incident affected: Hosted Email (Cluster B).