OpenSRS.COM Site Down

Incident Report for OpenSRS

Resolved

The issue affecting OpenSRS.COM has been resolved at this time.

Start: Wed 19 Nov 2025 10:40 UTC
End: Thu 20 Nov 2025 01:10:00 UTC
Posted Nov 20, 2025 - 01:12 UTC

Identified

WPEngine is performing scheduled extended maintenance, which may have up to 3 hours of service interuption.
Posted Nov 19, 2025 - 23:30 UTC

Investigating

The OpenSRS.COM site is currently down due to an issue with WPEngine. We have engaged WPEngine and will provide further updates.
Posted Nov 19, 2025 - 23:15 UTC
This incident affected: Reseller Support.