Sectigo Certificate Authority
Incident Report for OpenSRS
Resolved
The service has been completely restored. If you are still experiencing issues, please don't hesitate to contact us!

Incident Start Time: 05-04-2021 15:00:00 UTC
Incident End Time: 05-04-2021 20:57:00 UTC
Total Duration:~6 hrs
Posted May 04, 2021 - 21:47 UTC
Identified
Sectigo has confirmed that they are experiencing an internal outage.

They've communicated possible uptime within the next couple of hours.
Posted May 04, 2021 - 17:37 UTC
Update
We are still awaiting new developments from Sectigo
Posted May 04, 2021 - 16:25 UTC
Investigating
Be advised, we are receiving reporting regarding validation failures for new/renewed sectigo SSL products.

Our team are currently working with Sectigo to resolve the outage.
Posted May 04, 2021 - 15:51 UTC
This incident affected: SSL.