CentralNic Registry Connections
Incident Report for OpenSRS
Resolved
Connections to CentralNic have been restored. Services are functioning as they should.
Posted 2 months ago. May 14, 2019 - 13:39 UTC
Identified
The registry has confirmed that there is an issue on their end that needs to be addressed. Work continues to resolve the issue.
Posted 2 months ago. May 14, 2019 - 12:33 UTC
Investigating
We are currently having connection issues with the CentralNic registry. The registry might be experiencing a temporary outage or undergoing maintenance. Our operations team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of CentralNic domains. Existing domains will continue to resolve normally.

For a list of affected TLDs, please see: http://opensrs.help/chart
Posted 2 months ago. May 14, 2019 - 11:28 UTC
This incident affected: Domain Services (Other gTLDs, Other ccTLDs).