Cluster B - Sending errors
Incident Report for OpenSRS
Resolved
The migration process has now completed. We are pleased to report all services are now back to normal for Cluster B.

Thank you for your patience as we worked to resolve this.
Posted 18 days ago. Aug 28, 2019 - 21:17 UTC
Update
Seems like the communication is causing some confusion here, we would like to clarify the situation with some more details:

1. SMTP send error was identified and resolved. It caused by a combination of our storage NAS and the SMTP relay instances.
2. To address the storage device problem, we are migrating some services from it, which includes SMTP incoming service (Inbound mail delays).
Posted 18 days ago. Aug 28, 2019 - 19:10 UTC
Update
The migrating process is still on-going. A slight delay in the delivery of inbound email is expected. We will provide an update once this condition has passed.

Next Update: Based on the progress
Posted 18 days ago. Aug 28, 2019 - 18:11 UTC
Update
In order to mitigate the impact of the NAS problem identified, our operation team is in the process of migrating off of it. This will cause a slight delay in the delivery of inbound email. We will provide an update once this condition has passed.

Next update 18:00 UTC
Posted 19 days ago. Aug 28, 2019 - 16:57 UTC
Update
As we continue to monitor the problem, most users should be able to send normally again. We were able to track down the source of the issue to one of our storage NAS and SMTP relay instances. This failure contributed to the sending errors.

Next Update: 17:21 UTC
Posted 19 days ago. Aug 28, 2019 - 16:28 UTC
Monitoring
A fix has been implemented and users should be able to send normally again.

We will monitor the situation and provide more updates as they become available

Next Update: 16:10 UTC
Posted 19 days ago. Aug 28, 2019 - 15:39 UTC
Update
Our operations team is still investigating the cause and taking appropriate action to remedy the problem. By blocking source IP addresses which may be degrading our email services due to abuse.

Updates will be provided as soon as possible.

Next Update: 15:50 UTC
Posted 19 days ago. Aug 28, 2019 - 15:21 UTC
Update
Our operations team is still investigating the cause and taking appropriate action to remedy the problem. By blocking source IP addresses which may be degrading our email services due to abuse.

Updates will be provided as soon as possible.

Next Update: 15:30 UTC
Posted 19 days ago. Aug 28, 2019 - 15:20 UTC
Update
We are actively working with our operations team to get an ETA for the resolution. We will provide updates as soon as we have them.

Next Update: 16:00 UTC
Posted 19 days ago. Aug 28, 2019 - 15:05 UTC
Update
We are currently investigating an issue where users on Cluster B are receiving errors when they attempt to send an email. Users can still receive emails, the error is related to sending.

Error: SMTP Error (421): Connection to server failed.

Next Update: 15:00 UTC
Posted 19 days ago. Aug 28, 2019 - 13:58 UTC
Investigating
We are currently investigating an issue where users on Cluster B are receiving errors when they attempt to send an email. Users can still receive emails, the error is related to sending.

Error: SMTP Error (421): Connection to server failed.

We will provide updates as soon as they are available.
Posted 19 days ago. Aug 28, 2019 - 13:48 UTC
This incident affected: Hosted Email (Cluster B, Webmail).