Payment Processor
Incident Report for OpenSRS
Resolved
There was a temporary connection issue between OpenSRS and our payment processor. This incident has been resolved.

Start Time: 03/18/24 14:40 AM UTC
End Time: 03/18/24 15:44 AM UTC
Posted Mar 18, 2024 - 16:03 UTC
Investigating
We are currently experiencing a minor issue with our payment provider. Resellers may not be able to add funds to their account at the moment via Credit Card. We've reached out to our provider and will update shortly.
Posted Mar 18, 2024 - 15:38 UTC
This incident affected: Control Panels (Payment Gateway).