.DE Renewal Failures

Incident Report for OpenSRS

Resolved

Engineering has applied a fix. This incident has been resolved.
Posted Mar 20, 2026 - 20:02 UTC

Investigating

We are currently investigating an issue where some resellers may be unable to renew .DE domains. Any impact on other ccTLDs is also under investigation.

We will provide future updates on this issue.
Posted Mar 20, 2026 - 19:21 UTC
This incident affected: Domain Services (Core ccTLDs).