Digicert Order Processing Status
Incident Report for OpenSRS
Resolved
We were able to identify the issues causing new Digicert Trust orders to not appear on the Trust section of the Reseller Control Panel and all affected Digicert orders are now being displayed on the Trust page with the correct order status.
Posted Mar 22, 2024 - 15:47 UTC
Investigating
We are currently investigating an issue impacting Digicert orders not appearing in the Reseller Control Panel after submission. These orders are being processed by Digicert but the control panel is not showing the order after submission. If you have submitted a Digicert order but do not see it posted in your control panel, please refrain from making another order until this issue has been resolved. This is to avoid duplicate orders. Further updates will be provided.
Posted Mar 15, 2024 - 15:37 UTC
This incident affected: Control Panels (Reseller Control Panel) and SSL.