.Kiwi Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that the connection has been restored to the .Kiwi Registry. All pending orders can now be processed.
Posted 17 days ago. Aug 07, 2019 - 22:23 UTC
Investigating
We are currently experiencing connection issues with the .Kiwi registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .Kiwi domains. Existing domains will continue to resolve normally.
Posted 17 days ago. Aug 07, 2019 - 21:32 UTC
This incident affected: Domain Services (Other gTLDs).