Domain Services
Incident Report for OpenSRS
Resolved
Thank you for your patience. Our engineering team has identified the issue and corrected the problem.
lookup via https://tucowsdomains.com is now working correctly, and there should be no further interruptions

Incident Start Time: 08-05-2021 12:05:00 UTC
Incident End Time:08-06-2021 05:08:00 UTC
Total Duration:5 hours and 3 minutes.
Posted Aug 06, 2021 - 05:31 UTC
Update
We have identified the cause of the issue is with our provider and have reached out for an update.
Posted Aug 06, 2021 - 00:50 UTC
Update
We are continuing to investigate this issue.
Posted Aug 06, 2021 - 00:26 UTC
Investigating
We have identified an issue where users are unable to perform a provider lookup via https://tucowsdomains.com.

Our team is aware of the problem and is currently investigating this issue.
Posted Aug 06, 2021 - 00:22 UTC
This incident affected: Domain Services (WHOIS).