.Museum Registry Connection
Incident Report for OpenSRS
Resolved
The connection with the .Museum registry is restored. we are still awaiting a response from the registry regarding the cause of the connection issues and we will provide an update in the incident report when available.

Incident Start Time: 07-13-2021 04:05:00 UTC
Incident End Time:07-13-2021 05:35:00 UTC
Total Duration:1 Hour and 30 minutes
Posted Jul 13, 2021 - 17:09 UTC
Investigating
We are currently experiencing connection issues with the .Museum registry. We are currently investigating the issue.

This affects registrations, renewals, and management of .museum domains, already registered .museum domains will continue to resolve normally.
Posted Jul 13, 2021 - 04:46 UTC