End User Provider Search
Incident Report for OpenSRS
Resolved
This problem has been identified and corrected by our engineers. Provider lookups are now working as expected from: https://tucowsdomains.com/provider-search/

Incident Start Time: 05-13-2021 07:00:00 UTC
Incident End Time:05-13-2021 18:13:00 UTC
Total Duration:11 hours 13 minutes
Posted May 13, 2021 - 18:37 UTC
Update
The network team currently managing the site has found intermittent 504 gateway errors and captcha timeouts after 10 seconds when attempting to complete a provider search. We have escalated the issue to our partner service to investigate the cause of the timeouts. We will provide updates as they become available.

shopco.com can be used for provider lookups as an alternative for now.
Posted May 13, 2021 - 15:12 UTC
Investigating
The provider search feature available at the URL below is currently down.

Our team is investigating.

https://tucowsdomains.com/provider-search/
Posted May 13, 2021 - 11:21 UTC