.CA Registry Maintenance
Incident Report for OpenSRS
Resolved
The scheduled maintenance has been completed.
Posted Mar 20, 2020 - 06:42 UTC
Monitoring
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

The is scheduled to complete by 7am UTC March 20th.

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart
Posted Mar 20, 2020 - 04:13 UTC
This incident affected: Domain Services (Core ccTLDs).