Cluster B - Inbound Delays
Incident Report for OpenSRS
Resolved
Our operations team was able to address the issue and mail is being delivered at a healthy pace.
Posted 2 months ago. May 16, 2019 - 12:47 UTC
Investigating
We are currently experiencing inbound mail delays on Cluster B. This issue affects a small number of customers. Our operations team is investigating the issue.

We will provide an update once we have additional information.
Posted 2 months ago. May 16, 2019 - 12:07 UTC
This incident affected: Hosted Email (Cluster B).