Digicert Outage
Incident Report for OpenSRS
Resolved
Digicert has confirmed this issue to be resolved.

https://status.digicert.com/

Incident Start Time: 09-29-2021 16:50 UTC
Incident End Time: 09-29-2021 17:52 UTC
Total Duration: 1 Hour and 2 minutes
Posted Sep 29, 2021 - 17:53 UTC
Monitoring
Monitoring - A fix has been implemented and we are monitoring the results.

https://status.digicert.com/
Posted Sep 29, 2021 - 17:12 UTC
Investigating
Our vendor Digicert is reporting an outage with their CertCentral platform. Orders for RapidSSL, Thawte, Geotrust and Digicert may fail due to this.

https://status.digicert.com/

We will post updates as they come.
Posted Sep 29, 2021 - 16:50 UTC