Cluster A sending/receiving issue
Incident Report for OpenSRS
Resolved
We have implemented a fix to clear the backlog of queued emails and services have now returned to operational status.

Incident Start Time: 06-13-2022 13:00:00
Incident End Time:06-13-2022 15:19:00

Total Duration:2 hours and 19 minutes
Posted Jun 13, 2022 - 15:26 UTC
Update
We are continuing to work through the backlog of incoming communications. We will provide further updates as they become available.
Posted Jun 13, 2022 - 14:50 UTC
Investigating
We are currently experiencing an incident that is impacting Cluster A users. (Inbound Mail, Webmail). Our engineers have been engaged and have determined that all inbound communications are affected; however, outbound communications are unaffected. We are continuing to investigate.
Posted Jun 13, 2022 - 13:58 UTC
This incident affected: Hosted Email (Cluster A).