OpenSRS Chat Support
Incident Report for OpenSRS
Resolved
The issues we were seeing with our chat provider have now been resolved. Thanks for your patience.
Posted 4 months ago. Jul 12, 2017 - 20:22 UTC
Identified
Our web chat service provider is currently experiencing technical difficulties. We are working with them to resolve the problem .

We are still available via help@opensrs.com, as well as phone- https://opensrs.com/why/contact/.

We apologize for this inconvenience and appreciate your patience
Posted 4 months ago. Jul 12, 2017 - 13:01 UTC
This incident affected: Reseller Support.