.IT Registry Connections
Incident Report for OpenSRS
Resolved
The connection to the .IT registry remains stable. This incident is resolved.

Incident Start Time: 11-09-2022 21:30:00 UTC
Incident End Time: 11-09-2022 22:10:30 UTC
Total Duration: 40 minutes
Posted Nov 09, 2022 - 23:21 UTC
Monitoring
We are no longer seeing connectivity issues with the .IT registry. We will continue to monitor and update soon.
Posted Nov 09, 2022 - 22:39 UTC
Investigating
We are currently experiencing connection issues with the .IT registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .IT domains. Existing domains will continue to resolve normally.
Posted Nov 09, 2022 - 22:18 UTC
This incident affected: Domain Services (Other ccTLDs).