Digicert Trust Orders

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 14:53 UTC

Update

Digicert reports this issue is now resolved. We have confirmed submitted orders are now being processed as expected.
Thank you for your patience.
Posted Jun 23, 2025 - 14:53 UTC

Monitoring

There is an API submission issue preventing submitting or cancelling orders to Digicert. They are aware of this issue and are working on a fix on their end.

We will post any updates as they work to resolve this.
Posted Jun 23, 2025 - 13:29 UTC
This incident affected: SSL.