Cluster B Email Login Issues

Incident Report for OpenSRS

Resolved

That you for your patience. The Cluster B issues have now been resolved.
Posted Apr 04, 2026 - 12:14 UTC

Investigating

Please be aware we are currently experiencing issues with logging in to Cluster B email accounts via Webmail, IMAP and POP
Our engineers are aware and are working to resolve the issue. We will provide updates as they are available.
Posted Apr 04, 2026 - 10:58 UTC
This incident affected: Hosted Email (Cluster B, Webmail).