Service Degradation - Domains / opensrs.com / tucowsdomains.com
Incident Report for OpenSRS
Resolved
This issue has been resolved.
Posted 6 days ago. Sep 09, 2019 - 22:02 UTC
Update
Our investigation into the degradation continues.

The following services may be intermittently impacted:

tucowsdomains.com - WhoIs Queries, Report Abuse
opensrs.com - Signup page

We will provide an update as soon as we have more information. Thank you for your ongoing patience.
Posted 6 days ago. Sep 09, 2019 - 21:15 UTC
Update
We continue to investigate the degradation.

The following services may be intermittently impacted:

tucowsdomains.com - WhoIs Queries, Report Abuse
opensrs.com - Signup page
Posted 6 days ago. Sep 09, 2019 - 20:15 UTC
Investigating
We are currently experiencing an outage that is impacting Domains.

Server issues are currently causing some external sites to intermittently go down - tucowsdomains.com, opensrs.com

We are investigating and thank you for your patience.
Posted 6 days ago. Sep 09, 2019 - 19:16 UTC